Vítejte v systému nápovědy pro simulátor EPROM

  • Úvod
  • K čemu simulátor slouží
  • Napájení simulátoru
  • Typ simulace
  • LATCH registr v simulátoru
  • LATCH registr v aplikaci
  • Programové vybavení
  • Závěr

    • Takto vypadá SIMEPROM 32k

    Úvod

    Simulátor pamětí SIMEPROM 32 KB je zařízení, které umožňuje jednoduché odlaďování programového vybavení pro všechny typy procesorů. Složitý vývojový proces,spočívající v neustálém mazání pamětí EPROM a jejich přemísťování mezi programátorem a vyvíjeným zařízením velmi zdržuje a je pro vývoj neefektivní. Simulátor pamětí SIMEPROM je stále připojen k osobnímu počítači i k vyvíjené aplikaci a odpadají veškeré manipulace. Přeprogramování simulátoru trvá řádově jednotky sekund oproti asi 15 minutám u EPROM, takže odlaďování programu a oprava chyb je operativní. Počáteční investice je sice vyšší, ale vysoký komfort ji brzy vyrovná. Simulátor SIMEPROM 32 KB navíc obsahuje rozšířené možnosti pro práci s procesory s multiplexovanou sběrnicí.

    K čemu simulátor EPROM slouží

    Všechna zařízení používající procesor potřebují paměť, ve které je uložen řídící program.Tato paměť je buď uvnitř procesoru, nebo vně. Je- li paměť umístěna vně procesoru, je tvořena většinou pamětí EPROM nebo FLASH umístěnou v objímce. Umožňuje to snadný upgrade programového vybavení. Při vývoji programu pouze vyjmeme paměť z objímky a na její místo zasuneme konektor simulátoru EPROM. Ten se nyní chová jako obyčejná paměť EPROM, je však možno jej snadno a rychle z počítače naprogramovat. Simulátor navíc obsahuje vývod pro RESET procesoru, po jehož využití se zcela oprostíme od zásahů do zařízení během programování paměti. Nezřídka se tak celý proces změní na ovládání celého vývoje přímo z klávesnice počítače.Vývoj zařízení s procesory má své fáze a jednou z nich bývá sestavení celého řídícího jádra na nepájivém kontaktním poli. Má to výhodu ve snadné změně nevhodně zvolené konstrukce. Protože se často využívají obvody řady MCS 51, MCS 52 nebo 8085, které mají multiplexovanou datovou a adresovou sběrnici, byl do simulátoru přidán speciální mód. Při aktivaci tohoto módu připojíme na SIMEPROM 32KB sběrnici přímo, je tedy využit vnitřní LATCH registr simulátoru,Typ simulace a tím dojde k ušetření místa na kontaktním poli a hlavně ke zjednodušení propojení. Po odladění aplikace nesmíme ovšem zapomenout do konečné verze hardwaru zahrnout i LATCH registr.

    Praktické provedení redukce pro napájení

    Napájení simulátoru

    Celý simulátor je napájen z počítače přes redukci, která se připojí mezi počítač a klávesnici. Protože tento vývod napájení není jištěn, je do přívodního kablíku umístěno pojistkové pouzdro pro pojistku 2A. Dvoubarevná LED slouží k indikaci provozního stavu simulátoru. Po připojení napájení a při programování svítí červená barva, při simulování svítí barva zelená.

    Zapojení patice simulátoru Zapojení patice simulátoru

    Typ simulace

    Typ simulace je možno zvolit ze dvou typů. Typ simulace LATCH registr v aplikaci (obr.1) znamená, že simulátor bude naprogramován jako prostá paměť a jeho vnitřní zachytávací registr nebude využit.Pro naši aplikaci to znamená, že musíme mezi procesor a paměť zahrnout LATCH registr pro zachycení spodní části adresy z portu 0. Typ LATCH registr v simulátoru (obr.2) znamená, že zachytávací registr spodní části adresy je umístěn v simulátoru a my tedy připojíme adresové/bitové vodiče brány 0 rovnou na konektor simulátoru.Zapojení patice simulátoru se pro oba uvedené případy poněkud liší,detaily zapojení vývodů jsou na obrázcích.
    1. LATCH registr ve Vaší aplikaci 2. LATCH registr v simulátoru

    Programové vybavení

    Pro simulátor byl napsán ovládací program, pracující pod operačním systémem MS Windows (Podpora verzí Win 98,Win 2000 a Win NT).Tento program umožňuje načtení souboru ve formátu INTEL HEX nebo BIN a naprogramování simulátoru. Lze přepínat mezi módem simulace EPROM a LATCH + EPROM. Ovládací program lze spustit i z příkazové řádky.Tato funkce je výhodná při využití některých editorů kódu,které umožňují nastavit na některé klávesy nebo jejich kombinaci spuštění externích programů (např. překladače, komunikačního programu s monitorem nebo simulátoru). Pokud využijeme tuto možnost spuštění ovládacího programu, je nutno zadat jako první parametr jméno souboru určeného k naprogramování (samozřejmě s celou platnou cestou). Druhý parametr určuje typ naprogramování simulátoru, pokud je /L pak je simulátor naprogramován v módu LATCH registr v simulátoru. Bez druhého parametru je naprogramován do módu LATCH registr v aplikaci. Program provede naprogramování dat do simulátoru a pak se ukončí.Program vytvoří při svém spuštění ve stejném adresáři soubor SIMUL.INI, do kterého uloží při ukončení činnosti uživatelské nastavení ,jméno souboru s daty pro programování simulátoru a jeho umístění.Pokud program SIMULÁTOR spustíme z příkazové řádky bez parametrů může dojít ke dvěma alternativám : a) program se pokusí načíst data z simul.ini souboru a pokud se tak úspěšně stane pokračuje v činnosti b) pokud se načtení nepodaří (např. soubor simul.ini neexistuje) program se spustí v základním nastavení, kdy je možno zvolit pouze umístění souboru pro programování do simulátoru a teprve pak je možno pokračovat v činnosti. Po ukončení programu se nastavení i s jménem a plnou cestou souboru uloží. Při otevření okna pro výběr souboru je vždy zobrazen adresář,ze kterého uživatel otevřel soubor jako poslední. Tato funkce je podmíněna existencí simul.ini souboru.

    Takto vypadá aplikace

    Závěr

    Tento přístroj byl navržen tak, aby poskytoval vysoký komfort ladění programů. Spolu s produkty "Kompaktní převodník RS 232 -TTL" a "Monitor MCS 51 a 52" také vytvořenými na vývojovém pracovišti NEGATRON tvoří ucelené pracoviště pro ladění aplikací s jednočipovými mikropočítači řady MCS 51 a MCS 52. Simulátor je však využitelný pro kterýkoliv osmibitový procesor.
    Zde najdete podrobnější informace

    Nápovědu vytvořil David Hankovec 2002